Handy FB Scripts

Free FB Extensions

Social Applications
Free Social Applications
Neww
Social Media Scripts

G+,LinkedIn & Other

Ubuntu Security Notice USN-4049-1

======================================== =========================================================================
Ubuntu Security Notice USN-4049-1
July 08, 2019

glib2.0 vulnerability
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.10
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS

Summary:

GLib did not properly restrict directory and file permissions.

Software Description:
- glib2.0: GLib Input, Output and Streaming Library (fam module)

Details:

It was discovered that GLib created directories and files without properly
restricting permissions. An attacker could possibly use this issue to access
sensitive information.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.10:
libglib2.0-0 2.58.1-2ubuntu0.2
libglib2.0-bin 2.58.1-2ubuntu0.2

Ubuntu 18.04 LTS:
libglib2.0-0 2.56.4-0ubuntu0.18.04.4
libglib2.0-bin 2.56.4-0ubuntu0.18.04.4

Ubuntu 16.04 LTS:
libglib2.0-0 2.48.2-0ubuntu4.3
libglib2.0-bin 2.48.2-0ubuntu4.3

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/4049-1
CVE-2019-13012

Package Information:
https://launchpad.net/ubuntu/+source/glib2.0/2.58.1-2ubuntu0.2
https://launchpad.net/ubuntu/+source/glib2.0/2.56.4-0ubuntu0.18.04.4
https://launchpad.net/ubuntu/+source/glib2.0/2.48.2-0ubuntu4.3

Print Email

Copyright © 2016 Twitter/shreateh